UBOX S800 Gen2

UBVOD TV no more live TV channels after updated to Ver:2.2.6 says “something something失敗” All Movie side are OK. How can I fix it?



  • Thank you for an app but unable to downgrade a version. Clean cache data and delete reboot then installed ver:2.3.7 but it is come back ver:3.0.6 again even a icon is UBLIVE with HD is in it.

  • It's not downgrading version. the file 2.3.7 is version 3.0.9.

    You have to uninstall 3.0.6 first to install the new apk, you cannot just install 3.0.9 over 3.0.6

  • Yes it was ver: 3.0.9 sorry. I uninstalled 3.0.6 and installed 3.0.9, still [xxxx失敗]. My machine is almost 10 years old Android 4.4.0 and maybe CPU clock speed cannot keep up for new apps demand. I wander do you have old version of UBLive? A few years back at least that was working fine. Thank you

  • I have the exactly same UB2 as you have, it's working fine.

    What exactly happened? can you open UBLive on "Popular" or try to use the older version "UBTV" instead.

  • Actually I tried both apps, UBLIVE(3.0.9)and UBTV(2.1.9) neither of programs were soon as opened it says [unable to connect] and stay black screen nothing happen but movies side is work ok if I open the UBVOD (ver:2.2.6) and , I can watch UB(days-playback)?? App as well if I wait little, only I cannot watch app are LIVE channel apps. It start funny things start after last couple of upgrade for UBVOD, like if i wait little it will start play, or it is black but change channel then start play but now just stay black screen Taiwan China Korea Japan all channels says [cannot connect].

  • OK, I see...Try this, go to APP Market, open ublive, select reinstall (the middle button), click OK to delete, it will deleted and reinstall again, waited to 100% to complete and wait until the 100% disappeared then open the app see if it works. if it worked then reinstall all apps that has issue, do not use side loaded from your USB, must use the method mentioned above.

  • SomebodySomebody Junior Member

    This happened to my parent's ubox 4. No live channels.

    I had to set myDNS running on start up before the live channel apps can run.

  • Sorry I am not good for reply post thing.

    To:535four [waited to 100% to complete and wait until the 100% disappeared then open the app see if it works]  yes, this thing indicator is stopped at around 80% never show 100% then flash back to start screen, all square sections are flip. And it is not connect.


    To:Somebody  [set myDNS] you mean [DNS Changer] App? I don’t know how to do this.

    When I opened it, DNS provider /Google DNS (you can change a provider I guess)/ DNS1

    Not connected,  in side blue frames /START/CONNECT FASTEST DNS

    How do I do?

  • sleeslee Just Watchin`
    edited February 2022

    I have had the same problem with my S800 UBOX too since 2 weeks ago. I tried to unstall and re-install the UBLIVE and UBTV per @535four mentioned above in the APP Market, but still not working with the same error message of something like "聯接服務端失敗"(Fail connection to the server?)

    I wonder if we need to change DNS as the internet providers are blocking UBOX servers in Canada now? If so, how can I change the DNS?😭😭😭

  • SomebodySomebody Junior Member

    Yes, you need to connect to the suggested DNS either in the myDNS or DNSChanger app.

  • sleeslee Just Watchin`

    I installed the DNSChanger from the app market but working saying something like android 4.4.4 is too old from the S800 UBOX.... I will check the myDNS app, thanks.

  • SomebodySomebody Junior Member
    edited February 2022

    myDNS app looks like this in the apps section:


    You can also try downloading the DNS apps from https://ub6789.com using the web browser on your box.

  • sleeslee Just Watchin`

    Thanks again. I will try tomorrow and hope I can get the live TV working.... Is the myDNS app called "DNS專線" in your linked web site?

  • I don't have the experiences of connection error or server error, so I can't suggest anything, try DNS changer if still not working then you may need to restore your box to factory setting. But doing this may deactivated your box.

  • Hi @535four , did you ever upgrade S800 Gen2 firmware image? If not you are one of lucky guy :) My S800 is original firmware and I tried everything you and other guys were suggested and no change at all. I guess I have to get new box and gen2 would be my toy to factory reset and so on. Thanks.

  • In fact, I have 3 UB2 and one was flashed to S900 firmware, Android 4.4.2 and all went well. May be it's your location issue, I'm here in California USA.

    If you're plan to getting a new box, factory reset is your option. I did it many times with no issues but I hear some others need activation afterwards.

  • Hi old folks,it has been a long long time since my last post here, 8 years perhaps. I am the one that did try to flash a bricked Ubox S800 with the firmware 808, succeeded after numerous trials but back to square one after unplugging the power. Could not get it going despite how hard I tried to repeat the whole process over and over again. Gone to the bottom drawer as a result. Bought an Ubox1900 since and recently added another latest S9 model to enjoy. Out of boredom, I took that bricked S800 out from the drawer and played around with it again and guess what, it came back to life again but, no output from the HDMI source, AV is the only working source from the box. Did several factory reset change nothing. What I really want to say is doing a factory reset or repeat a firmware 808 flashing does not stop one having the App Market downloaded with all the apps but, if you flash it with the original firmware instead ,it will not. Although the box is working at the moment, however, I am experiencing exactly those problems of what yam96 is facing : 聯接服務端失敗. Using VPN nor DNS changing doesn't help . Side loading an older version of launcher and or live app to the box would make all apps in the App Market stop working all together. It would be nice to get a solution to it.

  • Incidentally, I got another Ubox S800 which stopped working a month ago and I tried the firmware flashing old trick again but it didn't work for me this time: the loading process stopped at the 20% mark and refused to go beyond that. Tried it numerous times and even left it on over night but no luck whatsoever. May be I need to put it in that lucky drawer like the other Ubox and pray for it?

  • I have contacted the UB customer service about the problem and see what they say. Perhaps it might need the Mac ID to get it unblocked, just like the good old days. I will keep you guys informed as soon as I have the response.

Sign In or Register to comment.