UBox 3 (S900)won't boot - flashing blue screen

edited August 2019 in UnblockTech UBox / UPad

It happened suddenly one day. When power up and after welcoming page, the screen turns blue & flashing. Power cycle doesn't work even with long rest in between. Ubox help suggested brushing firmware. Got their link via email and downloaded rar file. Following their advice (use Win 7 PC and SD card only), burning program failed to run. Here is what happened:

  1. Unzip rar file on Win 7 PC.
  2. Run the burning program: PhoenixCard.

No response.

Contacted Ubox again. Given another link to download. Repeat above, but same outcome.

That has nothing to do with the Ubox. The download might have been corrupted. Need help.

Also how does the RESET button at the back of Ubox work? It doesn't work like other devices - such as a router - on my Ubox.

The PhoenixCard program is V1.0.0.1 dated 2015-09-01

Post edited by ianm0 on


  • FIVE354FIVE354 Junior Member

    You not supposed to unzip the firmware to load. To reset the box, pushed a pin in button and hold, plug in the power at the same time wait for the screen appear then release. I hope I remember correctly.

  • edited August 2019

    Actually I tried that as well, but didn't work after I held the pin for well over one minute.

    I finally got the PhoenixCard software to run. Had to disable Windows Firewall. But another problem now. I use two different SD cards, one is brand new. Got same message:


    What could be the problem? Note: the burning software sees 4 "partitions" on my 32GB SD card, Windows sees only 1. I never partitioned it. Could that be the problem.

    Post edited by ianm0 on
  • padmanpadman Moderator

    What's the file system on these cards?

  • edited August 2019

    Don' think the card size is the problem. Found out from another thread that the solution is to install:

    Microsoft Visual C++ Redistributable 2008 (x86).

    Then the whole burning process completes as shown in tutorial. However, when I examined the contents of the SD card, it looks empty. Is that normal?

    Post edited by ianm0 on
  • Yes, it's normal, you can not read it when opened,

    Second through, have you try to use another power supply?

  • I did try another power supply. As I said two posts earlier, burning issue now fixed with Microsoft Visual C++ Redistributable 2008 (x86) installed.

    But now the box is dead - LED not lit. 😂 Power adapter still working with another Ubox. Probably from pressing the RESET pin for too long - as advised by several sources. I think one should never hold down that pin for too long. Resetting means shorting the circuit to ground. Doing that for too long will cause current overload.

    Time for a Gen6 Pro2.

  • May be try to unplug it back and forward few times see if it can bring back to life, wish I can put a hand on it, I've tried it on my friend's box and brought back to life. So, don't give up.

    Now the newest box is gen7 PROS with 2G RAM and 32G of ROM.

Sign In or Register to comment.